Problem
A consistent subset of users complaining of session performance issues, manifesting as sluggish desktop and application performance.
Identify Root Cause
Since the above issue is impacting a specific set of users, the first place you’ll want to go to is the Citrix Virtual Apps and Desktops display. To access this display, click Views then Citrix Virtual Apps and Desktops. This page is divided into 3 areas: App Servers and Published App & Desktops (for Citrix Virtual App, formerly XenApp, environments) and Virtual Desktops (for Citrix Virtual Desktop, formerly XenDesktop, environments). You’ll want to navigate to the applicable section for your environment (Published App & Desktop or Virtual Desktops) to troubleshoot further.
Each page includes user session data (both past and present) that allow you to track the complete user experience through the environment, from the login at the endpoint, all the way through the environment back to the underlying infrastructure, and present these data points over the course of the session so you can troubleshoot any issue that takes place during a user’s session. The commonality with these issues is that the same subset of power users was impacted on a recurring basis.
Since the display shows past and present data, you’ll want to use the search feature to filter the page to match a time period to analyze, for example a two-week period, and the specific users reporting issues.
Once the page is filtered, you can click on the user session to drill down into the individual sessions to analyze the session details. When troubleshooting slowness, the primary question you need to answer is whether the slowness is due to a network/connectivity or resource utilization. The quickest way to make that determination is by reviewing the user’s Network Latency, ICA RTT, and Connection Speed all which are on the Summary tab, which is the first tab of the drill down.
The first metric you’ll want to review is ICA Latency. ICA Latency is the time from when a user executes a keystroke or mouse click to when it is processed on the session host. It includes the network latency and any delay on the session host to process this request. Normally, users will notice slowness when there is a sustained ICA Latency over 250ms, and the experience will be significantly impacted when over 400ms for a sustained period of time (2-5mins).
When there is high ICA Latency, it should be compared first to the network latency to determine what is causing the delay. If Network latency is responsible for the spike, then networking is most likely the cause and you’ll want to review the Connection Performance metrics. If those metrics look OK then server performance and resource availability is the cause of the delay. When this is the case, you’ll first want to look at the ICA RTT then move over to the Server Performance tab of the drill down. This workflow is reflected in the data samples below. You’ll want to look for a direct correlation between RTT and processor utilization or RAM on each analyzed session.
Figure 1 - Session dialog - Logon Tab
In addition to just reviewing the Citrix user sessions, CPU consumption analysis can be done by going to the Dashboards - CPU page. There you can review the CPU Usage for a large group of machines to determine how widespread a CPU utilization condition might be. The same can be done for RAM by going to the Dashboards - Memory page.
Figure 2 - Dashboards - CPU Page
Figure 3 - Dashboards - Memory Page
Root Cause
In the case demonstrated above, by reviewing the underlying infrastructure along side the Citrix session metrics it is easy to determine if the root cause of session slowness is due to resource constraints in the environment.